投稿記事

Jekyll update to 3.4

13 Feb 2017

このサイトも飽きてきたので

そろそろ模様替えを考えています

現在は jekyll を使用していますが

ほかに何かないかと調べていると Gatsby を見つけました

ReactJsを利用しているので興味はありますが

今回はまず jekyll のアップグレードをしてみました。

ver 1.x から ver 3.4

ドキュメントも読まず、 いつものごとくいきなりアップデート開始

gem update jekyll

エラーが!!

Ruby 2.0 以上が必要だと

ruby 1.9.x を削除、 2.3.3をインストール

jekyll serve を実行してみる

エラーがいっぱい!!

どうにか動きました

皆さんはちゃんと

Upgrading from 0.x to 2.x

Upgrading from 2.x to 3.x

を見てから実行しましょう!!